08月≪ 2017年09月 ≫10月

123456789101112131415161718192021222324252627282930
2016.04/12(Tue)

XE8:Android開発でApplication does not support this deviceエラー

作成したアプリをLenovoのIdea Tabで動かしてみる。問題なく動く。

ところが、ほぼ同じコードでフォームがひとつないプログラムでは
「Application does not support this device」というエラーで動かない。

コードがほぼ同じはずなので意味がわからない。

結局、エンバカの以下の記事に従って修正。なぜか3カ所もあったのですべて直して
無事、動くようになった。
-------------------
この問題を回避するには:
IDE で配置マネージャ([プロジェクト|配置])を開き、次のエントリを見つけます。
[ローカル名]: libnative-activity.so
[リモート パス]: library\lib\armeabi\
このエントリのチェック ボックスをオフにして、このファイルが配置されないようにします。
-------------------
スポンサーサイト
23:44  |  Delphi  |  TB(0)  |  CM(0)  |  EDIT  |  Top↑

コメントを投稿する

URL
コメント
パスワード  編集・削除するのに必要
非公開  管理者だけにコメントを表示  (非公開コメント投稿可能)
 

▲PageTop

この記事のトラックバックURL

→http://derakun.blog74.fc2.com/tb.php/854-8b075a32
この記事にトラックバックする(FC2ブログユーザー)

この記事へのトラックバック

▲PageTop

 | BLOGTOP |